• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

ICG2000D/ICG3000F系列路由器配置GRE OVER IPSEC配置方法

2019-08-21 发表
  • 0关注
  • 0收藏,161浏览
粉丝:4人 关注:0人

组网及说明

MSR V7平台路由器GRE over IPSEC对接典型配置.docx

1 配置需求或说明

1.1  适用产品系列

本案例适用于如ICG2000DICG3000F系列的路由器。


1.2  配置需求及实现的效果

RTA路由器外网口G0/0的地址为1.1.1.1(模拟运营商公网固定地址环境),RTB路由器外网口G0/0的地址为2.2.2.1(模拟运营商公网固定地址环境),两个路由器外网口地址之间路由可达可以互相ping通。要对RTA路由器所在的内网(192.168.1.0/24)与RTB路由器所在的内网(172.16.1.0/24),实现两端内网终端通过GRE over IPsec VPN 隧道进行互访。

 

2 组网图


配置步骤

MSR V7平台路由器GRE over IPSEC对接典型配置.docx

3 配置步骤

3.1  配置路由器基本上网

#路由器基本上网配置省略, MSR V7路由器的上网具体设置步骤请参考“2.1.2 路由器外网使用固定IP地址上网配置方法章节中“MSR830-WiNet系列路由器基本上网(静态IP)命令行配置(V7案例

 

3.2  设置A路由器

#配置GRE隧道,

system-view

System View: return to User View with Ctrl+Z.

[H3C]interface Tunnel0 mode gre

[H3C-Tunnel0]ip address 10.1.2.1 24

[H3C-Tunnel0]source 1.1.1.1

[H3C-Tunnel0]destination 2.2.2.1

#配置一个访问控制列表3000,定义由子网1.1.1.0/24去子网2.2.2.0/24的数据流,封装GRE数据流。

[H3C]acl advanced 3000

[H3C-acl-ipv4-adv-3000]rule permit ip source 1.1.1.0 0.0.0.255 destination 2.2.2.0 0.0.0.255

[H3C-acl-ipv4-adv-3000]quit

#配置公网口NAT要关联的ACl 3001,作用是把IPSec感兴趣流从NAT转换的数据流deny掉,防止IPSec数据流被NAT优先转换

[H3C]acl number 3001

[H3C-acl-adv-3001]rule 0 deny ip source 1.1.1.0 0.0.0.255 destination 2.2.2.0 0.0.0.255

[H3C-acl-adv-3001]rule 1 permit ip

[H3C-acl-adv-3001]quit

#创建一条IKE提议1,指定IKE提议使用的认证算法为MD5,加密算法为3des-cbc

[H3C]ike proposal 1

[H3C-ike-proposal-1]authentication-algorithm md5  

[H3C-ike-proposal-1]encryption-algorithm 3des-cbc   

[H3C-ike-proposal-1]quit

#创建并配置IKE keychain,名称为RTA

[H3C]ike keychain RTA

#配置对端IP地址为2.2.2.1,使用的预共享密钥为明文123456

[H3C-ike-keychain-RTA]pre-shared-key address 2.2.2.1 255.255.255.0 key simple 123456

[H3C-ike-keychain-RTA]quit

#创建并配置IKE profile,名称为RTA,引用上面配置的keychain RTA,配置本地地址为本端的公网接口地址1.1.1.1,对端地址为对端公网接口地址2.2.2.1,引用之前配置IKE提议1

[H3C]ike profile RTA

[H3C-ike-profile-RTA]keychain RTA    

[H3C-ike-profile-RTA]local-identity address 1.1.1.1

[H3C-ike-profile-RTA]match remote identity address 2.2.2.1 255.255.255.0

[H3C-ike-profile-RTA]proposal 1    

[H3C-ike-profile-RTA]quit

#配置IPsec安全提议1ESP协议采用的加密算法为3des-cbc,认证算法为md5

[H3C]ipsec transform-set 1

[H3C-ipsec-transform-set-1]esp encryption-algorithm 3des-cbc   

[H3C-ipsec-transform-set-1]esp authentication-algorithm md5  

[H3C-ipsec-transform-set-1]quit

#创建IPsec安全策略,名称为RTA,序列号为1,设置对端地址为对端公网地址2.2.2.1,引用之前创建的ACL3000,引用之前创建的IKE profile RTA,引用之前的IPSec安全提议1

[H3C]ipsec policy RTA 1 isakmp

[H3C-ipsec-policy-isakmp-RTA-1]remote-address 2.2.2.1

[H3C-ipsec-policy-isakmp-RTA-1]security acl 3000  

[H3C-ipsec-policy-isakmp-RTA-1]transform-set 1    

[H3C-ipsec-policy-isakmp-RTA-1]ike-profile RTA

[H3C-ipsec-policy-isakmp-RTA-1]quit

#设置外网口做NAT转换的时候关联ACL 3001 (如果之前已经在外网口配置了 nat outbound,需要先undo掉),并将IPSec安全策略RTA应用在外网接口

[H3C]interface GigabitEthernet 0/0

[H3C-GigabitEthernet0/0]undo nat outbound

[H3C-GigabitEthernet0/0]nat outbound 3001

[H3C-GigabitEthernet0/0]ipsec apply policy RTA

[H3C-GigabitEthernet0/0]quit

#配置到对端内网的路由

[H3C]ip route-static 172.16.1.0 24 Tunnel 0

#保存配置

[H3C]save force


3.3  设置B路由器

#配置GRE隧道,

system-view

System View: return to User View with Ctrl+Z.

[H3C]interface Tunnel0 mode gre

[H3C-Tunnel0]ip address 10.1.2.2 24

[H3C-Tunnel0]source 2.2.2.1

[H3C-Tunnel0]destination 1.1.1.1

#配置一个访问控制列表3000,定义由子网1.1.1.0/24去子网2.2.2.0/24的数据流,封装GRE数据流。

[H3C]acl advanced 3000

[H3C-acl-ipv4-adv-3000]rule permit ip source 2.2.2.0 0.0.0.255 destination 1.1.1.0 0.0.0.255

[H3C-acl-ipv4-adv-3000]quit

#配置公网口NAT要关联的ACl 3001,作用是把IPSec感兴趣流从NAT转换的数据流deny掉,防止IPSec数据流被NAT优先转换

[H3C]acl number 3001

[H3C-acl-adv-3001]rule 0 deny ip source 2.2.2.0 0.0.0.255 destination 1.1.1.0 0.0.0.255

[H3C-acl-adv-3001]rule 1 permit ip

[H3C-acl-adv-3001]quit

#创建一条IKE提议1,指定IKE提议使用的认证算法为MD5,加密算法为3des-cbc

[H3C]ike proposal 1

[H3C-ike-proposal-1]authentication-algorithm md5  

[H3C-ike-proposal-1]encryption-algorithm 3des-cbc   

[H3C-ike-proposal-1]quit

#创建并配置IKE keychain,名称为RTA

[H3C]ike keychain RTA

#配置对端IP地址为1.1.1.1,使用的预共享密钥为明文123456

[H3C-ike-keychain-RTA]pre-shared-key address 1.1.1.1 255.255.255.0 key simple 123456

[H3C-ike-keychain-RTA]quit

#创建并配置IKE profile,名称为RTA,引用上面配置的keychain RTA,配置本地地址为本端的公网接口地址2.2.2.1,对端地址为对端公网接口地址1.1.1.1,引用之前配置IKE提议1

[H3C]ike profile RTA

[H3C-ike-profile-RTA]keychain RTA    

[H3C-ike-profile-RTA]local-identity address 2.2.2.1

[H3C-ike-profile-RTA]match remote identity address 1.1.1.1 255.255.255.0

[H3C-ike-profile-RTA]proposal 1    

[H3C-ike-profile-RTA]quit

#配置IPsec安全提议1ESP协议采用的加密算法为3des-cbc,认证算法为md5

[H3C]ipsec transform-set 1

[H3C-ipsec-transform-set-1]esp encryption-algorithm 3des-cbc   

[H3C-ipsec-transform-set-1]esp authentication-algorithm md5  

[H3C-ipsec-transform-set-1]quit

#创建IPsec安全策略,名称为RTA,序列号为1,设置对端地址为对端公网地址1.1.1.1,引用之前创建的ACL3000,引用之前创建的IKE profile RTA,引用之前的IPSec安全提议1

[H3C]ipsec policy RTA 1 isakmp

[H3C-ipsec-policy-isakmp-RTA-1]remote-address 1.1.1.1

[H3C-ipsec-policy-isakmp-RTA-1]security acl 3000  

[H3C-ipsec-policy-isakmp-RTA-1]transform-set 1    

[H3C-ipsec-policy-isakmp-RTA-1]ike-profile RTA

[H3C-ipsec-policy-isakmp-RTA-1]quit

#设置外网口做NAT转换的时候关联ACL 3001 (如果之前已经在外网口配置了 nat outbound,需要先undo掉),并将IPSec安全策略RTA应用在外网接口

[H3C]interface GigabitEthernet 0/0

[H3C-GigabitEthernet0/0]undo nat outbound

[H3C-GigabitEthernet0/0]nat outbound 3001

[H3C-GigabitEthernet0/0]ipsec apply policy RTA

[H3C-GigabitEthernet0/0]quit

#配置到对端内网的路由

[H3C]ip route-static 192.168.1.0 24 Tunnel 0

#保存配置

[H3C]save force


3.4  验证配置结果

MSR V7平台路由器GRE over IPSEC对接典型配置.docx

#RTA路由器上带源ping RTB路由器内网网关地址


配置关键点

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作