• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

AR28/AR46系列路由器L2VPN-Kompella典型配置

2006-09-07 发表
  • 0关注 ,130浏览
粉丝: 关注:

AR28/AR46系列路由器L2VPNKompella典型配置

【需求】

CE-AS2/0/0CE-BS2/0/0之间建立一条本地的L2VPN连接CE-AS2/0/1CE-CS2/0/0建立一条远程的L2VPN连接。

【组网图】

 

【配置脚本】

CE-A配置脚本

#

sysname CE-A

#

radius scheme system

#

domain system

#

interface Serial2/0/0

link-protocol ppp

ip address 192.168.11.1 255.255.255.0

#

interface Serial2/0/1

link-protocol ppp

ip address 192.168.21.1 255.255.255.0

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

CE-B配置脚本

#

sysname CE-B

#

radius scheme system

#

domain system

#

interface Serial2/0/0

link-protocol ppp

ip address 192.168.11.2 255.255.255.0

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

PE-A配置脚本

#

sysname PE-A

#

router id 1.1.1.1

#

mpls lsr-id 1.1.1.1

#

mpls l2vpn                                        /启用MPLS L2VPN/

#

#

radius scheme system

#

mpls

#

mpls ldp

#

domain system

#

interface Serial2/0/0

link-protocol ppp

#

interface Serial2/0/1

link-protocol ppp

#

interface Serial2/0/2

link-protocol ppp

#

interface Serial2/0/3

link-protocol ppp

ip address 10.0.0.1 255.255.255.252

mpls

mpls ldp enable

#

interface NULL0

#

interface LoopBack0

ip address 1.1.1.1 255.255.255.255

#

bgp 100

undo synchronization

group inter internal

peer 3.3.3.3 group inter                          /PE-B建立BGP邻居/

peer 3.3.3.3 connect-interface LoopBack0

#

l2vpn-family                                      /创建L2VPN地址族/

peer inter enable                                 /使能peer inter/

#

ospf 1

area 0.0.0.0

network 1.1.1.1 0.0.0.0

network 10.0.0.0 0.0.0.3

#

mpls l2vpn vpna encapsulation ppp                 /创建VPN实例“vpna”,封装为ppp/

route-distinguisher 100:1                         /RD=100:1/

vpn-target 100:1 import-extcommunity              /RT=100:1/

vpn-target 100:1 export-extcommunity

mtu 1500

ce ce-a id 1 range 10 default-offset 0            /创建cece-a/

connection ce-offset 3 interface Serial2/0/1

/配置和CE-C的远程连接/

connection ce-offset 2 interface Serial2/0/0

 /配置和CE-B的本地连接/

ce ce-b id 2 range 10 default-offset 0            /创建cece-b/

connection ce-offset 1 interface Serial2/0/2    /配置和CE-A的本地连接/

#

#

user-interface con 0

user-interface vty 0 4

#

return

 

P配置脚本

#

sysname P

#

router id 2.2.2.2

#

mpls lsr-id 2.2.2.2

#

radius scheme system

#

mpls

#

mpls ldp

#

domain system

#

interface Serial2/0/0

link-protocol ppp

ip address 10.0.0.2 255.255.255.252

mpls

mpls ldp enable

#

interface Serial2/0/1

link-protocol ppp

ip address 10.0.0.5 255.255.255.252

mpls

mpls ldp enable

#

interface NULL0

#

interface LoopBack0

ip address 2.2.2.2 255.255.255.255

#

ospf 1

area 0.0.0.0

network 2.2.2.2 0.0.0.0

network 10.0.0.0 0.0.0.3

network 10.0.0.4 0.0.0.3

#

user-interface con 0

user-interface vty 0 4

#

return

 

PE-B配置脚本

#

sysname PE-B

#

router id 3.3.3.3

#

mpls lsr-id 3.3.3.3

#

mpls l2vpn                                        /启用MPLS L2VPN/

#

#

radius scheme system

#

mpls

#

mpls ldp

#

domain system

#

interface Serial2/0/0

link-protocol ppp

ip address 10.0.0.6 255.255.255.252

mpls

mpls ldp enable

#

interface Serial2/0/1

link-protocol ppp

#

interface NULL0

#

interface LoopBack0

ip address 3.3.3.3 255.255.255.255

#

bgp 100

undo synchronization

group inter internal

peer 1.1.1.1 group inter                          /PE-A建立BGP邻居/

peer 1.1.1.1 connect-interface LoopBack0

#

l2vpn-family                                      /创建L2VPN地址族/

peer inter enable                                 /使能peer inter/

#

ospf 1

area 0.0.0.0

network 3.3.3.3 0.0.0.0

network 10.0.0.4 0.0.0.3

#

mpls l2vpn vpna encapsulation ppp                 /创建VPN实例“vpna”,封装为ppp/

route-distinguisher 100:1                         /RD=100:1/

vpn-target 100:1 import-extcommunity              /RT=100:1/

vpn-target 100:1 export-extcommunity

mtu 1500

ce ce-c id 3 range 10 default-offset 0            /创建cece-c/

connection ce-offset 1 interface Serial2/0/1      /配置和CE-A的远程连接/

#

#

user-interface con 0

user-interface vty 0 4

#

return

 

CE-C配置脚本

#

sysname CE-C

#

radius scheme system

#

domain system

#

interface Serial2/0/0

link-protocol ppp

ip address 192.168.21.2 255.255.255.0

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return

                                                                

【验证】

查看PE-A的l2vpn连接状态:

<PE-A>disp mpls l2vpn connection                                               

total connections: 3,                                                           

connections: 3 up, 0 down, 2 local, 1 remote, 0 unknown                        

                                                                               

VPN-Instance Name: vpna,                                                        

total connections: 3,                                                          

connections: 3 up, 0 down, 2 local, 1 remote, 0 unknown                        

                                                                               

  CE Name: ce-a, id: 1,                                                        

  Rid type status peer-id         route-distinguisher   intf                   

  3   rmt  up     3.3.3.3         100:1                 Serial2/0/1            

  2   loc  up     ---             ---                   Serial2/0/0            

                                                                               

  CE Name: ce-b, id: 2,                                                        

  Rid type status peer-id         route-distinguisher   intf                   

  1   loc  up     ---             ---                   Serial2/0/2 

 

 

查看PE-B的l2vpn连接状态:

<PE-B>disp mpls l2vpn connection                                               

total connections: 1,                                                           

connections: 1 up, 0 down, 0 local, 1 remote, 0 unknown                        

                                                                               

VPN-Instance Name: vpna,                                                        

total connections: 1,                                                          

connections: 1 up, 0 down, 0 local, 1 remote, 0 unknown                        

                                                                               

  CE Name: ce-c, id: 3,                                                        

  Rid type status peer-id         route-distinguisher   intf                   

  1   rmt  up     1.1.1.1         100:1                 Serial2/0/1

 

 

【提示】

Kompella方式的VC标签由MP-BGP来发布。下图为二层标签示意图。

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作