• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

AP跨三层,终端无法获取IP

2020-10-07提问
  • 0关注
  • 0收藏,149浏览
粉丝:0人 关注:0人

问题描述:

所有Vlan在三层交换机上

三层交换机已开启Option 43

路由AC已发现AP并上线

终端无法获取IP

官方客服小姐姐也没搞定

组网及组网描述:

路由:ip:192.168.8.1

交换:IP:192.168.8.254    Vlan100,Vlan110...

AP:IP:获取Vlan100:192.168.100.1

终端:无法获取IP

交换机到路由已开启Trunk

交换机到AP已开启Trunk

最佳答案

粉丝:3人 关注:0人

你好,不知道你是本地转发还是集中转发,就2种情况都说一下,另外建议将配置贴出来,不知道你的配置有没有什么问题?

一、如是查集中转发(默认),这种情况下交换机到ap的端口直接配置为access类型加入相应的管理vlan即可,因为数据转发靠的隧道,client获取ip地址的dhcp报文也是通过隧道发送到ac,ac解封装后再发送到核心交换机,所以ac---核心交换机的之间是trunk链路并放行业务vlan和管理vlan。你的ap能正常上线,证明option字段没问题,重点检查一下地址池配置和是否透传业务vlan

以下是参考脚本

#配置wan口地址
interface g1/0/5
ip address dhcp-alloc


#配置ap自动关联ac,自动固化ap
wlan auto-ap enable
wlan auto-persistent enable


#配置管理地址池,并在地址池中排除ac地址
dhcp enable
dhcp server ip-pool 110
gateway-list 192.168.110.1
network 192.168.110.0
dns 114.114.114.114 8.8.8.8
forbidden-ip 192.168.100.254

#ac、ap不同网段,配置option43字段,指定AC的IP地址192.168.100.254,后四位为ip地址(16进制)
option 43 hex 80 07 00 00 01 C0 A8 64 FE


#配置client地址池
dhcp server ip-pool 200
gateway-list 192.168.200.1
network 192.168.200.0
dns 114.114.114.114 8.8.8.8
forbidden-ip 192.168.200.254


#创建无线服务模板1,并进入无线服务模板视图,创建ssid为H3C并使能模板配置AKM为PSK,配置PSK密钥,使用明文的字符串12345678作为共享密钥。配置CCMP为加密套件,配置rsn为安全信息元素。
#配置最大接入用户数

wlan service-template 1
ssid h3c-test
client max-count 20
akm mode psk
preshared-key pass-phrase simple 12345678
cipher-suite ccmp
security-ie rsn
service-template enable


#配置不加密不认证的服务模板
wlan service-template test
ssid h3c-test
service-template enable



#进入默认组AP的Radio视图,并绑定service-template,绑定业务vlan200
wlan ap-group default-group
ap-model wap712c-li
radio1
service-template 1 vlan 200
radio enable
quit
radio 2
channel 6
service-template 2 vlan 200
radio enable
return 


二、本地转发的情况:需要由ac下发apcfg文件将ap的端口设置为trunk并透传业务vlan,并在ap上创建一个业务vlan,(详细内容见附件)。client的数据是由ap向交换机直接转发,所以需要在交换机连接ap的trunk放行业务和管理vlan。

以下是配置脚本,请参考:

#AC配置:服务模板,(1)第3行配置本地转发
wlan service-template 1
ssid h3c-ap
vlan 200
client forwarding-location ap vlan 200
akm mode psk
preshared-key pass-phrase cipher $c$3$4HrUse+v8qMzvs3KI8iYo+UhkyXhAMA+d3Kh
cipher-suite ccmp
cipher-suite tkip
security-ie rsn
security-ie wpa
service-template enable

#AC上联SW交换机端口设置为trunk,并允许业务和管理vlan通过
interface GigabitEthernet1/0/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 4 100 200



#SW交换机配置:SW连接AP端口设置为trunk,并允许vlan1(AP端口初如为vlan1),管理、业务通过,并设置pvid为100
interface GigabitEthernet1/0/45
description link_to_ap
port link-type trunk
port trunk permit vlan 1 100 200
port trunk pvid vlan 100

#SW交换机下联ac端口配置为trunk,并允许业务和管理vlan通过
interface GigabitEthernet1/0/47
description link_to_ac
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 100 200

#在AP组配置MAP文件下发(注:可远程telnet到ap,然后dis cur查看map文件是否下发成功)
wlan ap-group xx
vlan 1
ap-model wap712c-li
map-configuration cfa0:/apcf.txt


apcfg文件内容:

system-view
vlan 200
quit
interface GigabitEthernet 1/0/1
port link-type trunk
port trunk permit vlan 200

1 个回答
粉丝:4人 关注:0人

本地转发还是集中式转发,业务段是那个vlan,

本地和集中都试过了 Vlan100

女施主,请自重 发表时间:2020-10-07

路由器是三层接口吗

zhiliao_pdGY6 发表时间:2020-10-07

上行trunk口的pvid改成100试一下

zhiliao_pdGY6 发表时间:2020-10-07
回复zhiliao_pdGY6:

对的

女施主,请自重 发表时间:2020-10-07

好的 我中午试下

女施主,请自重 发表时间:2020-10-07
回复zhiliao_pdGY6:

不得行,立马就断网了

女施主,请自重 发表时间:2020-10-07

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明