• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

原设备是Cisco的,现在打算替换成华三设备,对于cpos接口该怎么配置呀?

2021-05-18提问
  • 0关注
  • 1收藏,266浏览
粉丝:0人 关注:12人

问题描述:

原设备是Cisco的,现在打算替换成华三设备,对于cpos接口该怎么配置呀? 怎么区分时隙呀? 华三打不出Serial9/0/0.1/1/1/1:0这种接口呀。我下面的配置是在模拟器上做的,不知道对不对。麻烦大家帮忙看下。

组网及组网描述:


最佳答案

粉丝:107人 关注:2人


Cisco sonet Cpos STM 配置示例

CPOS(通道化POS)模块

模块概述

CPOS是通道化SDH/SONET接口模块的简称,其中C表示Channelized,POS表示Packet Over SDH/Sonet。它充分利用了SDH体制的特点,提供对带宽精细划分的能力,可减少组网中对路由器低速物理接口的数量要求,增强路由器的低速接口汇聚能力,并提高路由器的专线接入能力。

1CPOS支持1个STM-1/OC-3多通道接口模块,支持155.52Mbps的通信速率。

1CPOS接口卡分为1CPOS(E)和1CPOS(T)两种型号,其中1CPOS(E)接口卡支持E1制式,而1CPOS(T)接口卡支持T1制式。

1CPOS接口模块分别提供用于AR 28系列的RT-1CPOS(E)、RT-1CPOS(T)和用于AR 46系列的RT-FIC-1CPOS(E)、RT-FIC-1CPOS(T)模块,通过PCI接口与CPU进行通讯,完成STM-1通道化POS接口数据的收发。其分类如下:

1、支持净通道(非成帧)E1(最多63个)或T1(最多84个)。

2、支持非通道化(成帧)E1(最多63个)或T1(最多84个)。

3、支持通道化到64K,但是最多256个逻辑通道。

使用方法

目前CPOS接口只实现E1、T1向STM-1的复用。实际应用中,不同的国家和地区可能采用不同的复用路径,为保证互通, CPOS提供multiplex mode命令,使用户可以选择AU-3(即T1制式)还是AU-4(即E1制式)复用路径(我国SDH体制选用的是AU-4的复用路径)。

在目前的实现中,CPOS通道化出的E1支持净通道(clear channel,又称为非成帧模式,unframed)和非通道化(unchannelized)两种工作模式。在净通道模式下,E1通道不分时隙,形成一个速率为2.048Mbps的串口(相当于一个2.048Mbps的同步串口)。在非通道化模式下,E1通道除时隙0以外的31个时隙可以捆绑为一个串口使用(相当于一个E1-F端口)。

CPOS通道化出的T1支持净通道和通道化(channelized)两种工作模式。在净通道模式下,T1通道不分时隙,形成一个速率为1.544Mbps的串口(相当于一个1.544Mbps的同步串口)。在通道化模式下,T1通道的24个时隙可以任意捆绑为串口使用(相当于一个cT1端口),在这种情况下可以通道化到64Kbps,但是最多支持256个逻辑通道。

此次XXX行营业部到部分支行和网点的广域网线路改造采用了STM1-E1 的连接形式,下面我把这次线路调试的一些经验和心得介绍给大家,希望能够对大家日后的工作有所帮助。如果这篇文档中有什么不足或者不对的地方,还希望大家能够指出。

 

一,STM1介绍:

STM,Synchronous Transport Module,是基于电信SDH骨干网传输的一种时分复用技术,与CE1线路很类似。说的简单点,一个STM模块就是一个多通道的E1模块。一个STM模块可以配置为最大支持63个E1线路,而每一个E1线路可以根据用户的需要配置为2M的带宽,或者再细分成N×64K的channel-group的形式。

 

根据ITU-T的G.703的定义,国际上流行的STM复用技术主要以下两种:

 

a,E1――C-12――VC-12――TU-12×3――TUG-2×7――VC-3×1――AU-3×3――AUG×1――STM-1

 

b,E1――C-12――VC-12――TU-12×3――TUG-2×7――TUG-3×3――VC-4×1――AU-4×1-AUG×1――STM-1

 

目前中国的电信多采用第二种复用路径,一般习惯成为373复用,简单的理解,一个E1的帧首先被装进一个叫做C-12的容器,再被装进VC-12的容器,然后形成一个叫做附属单元的东东(tu-12),然后三个tu-12被复用成一个附属单元组tug-2,接下来7个tug-2被复用成一个更大的单元组,叫做tug-3,后面再用一个叫做VC-4的更大的容器装下3个tug-3,转换为一个au-4,在经过转化,最后成为STM-1的帧格式(有点晕:()。

 

在给客户安装时需要注意:

 

1, Cisco7507的VIP-2和以下版本的VIP板卡不支持STM-1模块。

 

2, 一块STM-1模块最多只能划分256个channel group。

 

3, 有些高版本的IOS并不支持STM卡,如果装上去无法识别,可以适当的调整IOS的版本。

 

二,PA-MC-STM-1的配置

由于电信提供的STM/E1的服务是基于SDH这种透明的传输技术的,所以STM的配置很简单,而且很多参数可以我们自己定制,而不需要电信提供,比如E1的数据帧是否成帧,具体成帧的格式等等。

 

在此次xx电信提供的工单上只有一个叫做时隙的参数,比如从省行营业部到五一路支行使用第1个时隙传输,到湖大支行使用第2时隙传输…..到白沙路支行使用第63时隙传输,所以我们首先要搞清楚这个时隙与具体的TU-12×3――TUG-2×7――TUG-3×3的对应关系(Cisco的配置必须要知道这个对应关系,否则无法配置,而华为的CPOS卡则只需要知道时隙就可以了),才能在STM模块上做具体的配置,一般的对应关系如下

 

AUG TUG-3 TUG-2 TU-12 E1时隙

 

1    1    1    1    1

        2

   1    1    3    3

        4

1    1    2    2    5

        6

        7

        8

1    1    3    3    9

1        1    10

1    1      2    11

   1      3    12

         13

         14

         15

         16

         17

         18

         19

         20

         21

         22

         23

         24

         25

         26

         27

         28

以下依次类推:

 

1      7    3   63

传输时隙计算公式:

常见的时隙顺序计算公式为:VC12序号=(TUG3编号-1)*21+(TUG2编号-1)*3+TU12编号

华为的时隙顺序计算公式为:VC12序号=TUG3编号+(TUG2编号-1)*3+(TU12编号-1)*21

对照表

时隙  常见编号华为编号  时隙  常见编号华为编号  时隙  常见编号 华为编号

1-1-1                2-1-1    22        2     3-1-1     43          3

1-1-2          22       2-1-2    23       23     3-1-2    44        24

1-1-3           43       2-1-3    24       44     3-1-3    45        45

1-2-1                 2-2-1    25           3-2-1     46           6

1-2-2           25       2-2-2    26        26    3-2-2    47         27

1-2-3           46       2-2-3    27        47    3-2-3    48        48

1-3-1                2-3-1    28           3-3-1     49          9

1-3-2          28       2-3-2    29        29    3-3-2     50        30

1-3-3          49       2-3-3    30       50     3-3-3    51         51

1-4-1    10       10      2-4-1    31        11    3-4-1    52         12

1-4-2    11       31      2-4-2    32        32    3-4-2      53       33

1-4-3    12       52      2-4-3    33        53    3-4-3     54        54

1-5-1    13        13      2-5-1    34        14    3-5-1    55         15

1-5-2    14       34      2-5-2    35        35    3-5-2    56         36

1-5-3    15       55      2-5-3    36        56    3-5-3    57        57

1-6-1    16       16      2-6-1    37        17    3-6-1    58        18

1-6-2    17        37      2-6-2    38       38     3-6-2    59         39

1-6-3    18       58      2-6-3    39        59    3-6-3    60        60

1-7-1    19       19      2-7-1    40        20    3-7-1    61         21

1-7-2    20       40      2-7-2    41        41    3-7-2     62         42

1-7-3    21         61     2-7-3    42        62    3-7-3    63          63

下面是具体的配置步骤:

 

Router(config)#

controller sonet 8/0/0 -进入STM模块的配置模式

 

Router(config-controller)# framing SDH -定义STM的帧模式(一共有SDH和sonet两个参数,SDH是默认值)

 

Router(config-controller)#

 

aug mapping au-4 ??-定义使用的复用路径(一共有au-3和au-4两个参数,au-4是默认值)

 

Router(config-controller)#

 

au-4 au-4-number tug-3 tug-3-number -配置指定的tug-3,其中au-4-number永远为1,tug-3-number为1到3

 

Router(config-ctrlr-tug3)#

 

mode c-12 定义一个tug-3可以被分为21个tu-12,每一个tu-12可以承载一个E1线路

 

Router(config-ctrlr-tug3)#

 

tug-2 tug-2-number e1 e1-number unframed 在一个TUG-3上建立一个非成帧的逻辑E1通道

 

 

在做完这个配置后,路由器会虚拟出一个串口来,这点与CE1线路很类似,简单的理解一个串口就是一个TU-12 ――TUG-2 ――TUG-3的复用关系,也就是一个2M线路,对应电信提供的一个时隙

 

Router(config)# interface serial

 

slot/port-adapter/port.au-4-number/tug-3-number/tug-2-

 

number/ e1-number:channel-group-number 进入这个串口的配置模式,对于非成帧的E1线路,channel-group-number永远为0

 

Router(config-if)#ip address 16.202.99.165 255.255.255.255

 

Router(config-if)# encapsulation ppp 在串口的两端封装PPP

 

 

三,配置总结:

1, 首先要搞清楚时隙对应关系,这个可以按照上面的表自己计算,如果不放心的话可以让电信帮助查。(在他们的设备上可以查出,但是他们一般懒的提供给客户)

 

2,对于E1的帧格式,可以成帧,也可以不成帧,如果客户不要求在E1线路上再划分具体的N×64K的时隙,就可以配置成unframed格式,比较省事,但是要注意最后的E1-V。35转换器的开关设置。

 

3, 对于线路时钟,可以使用电信的SDH网提供的时钟,另外Cisco的STM卡也可以提供时钟,看自己的爱好了。

 

4, 在配置串口上,一定要记住两端都要封装PPP,否则不通,Cisco路由器串口的默认封装为HDLC。

 

下面是xxx行营业部路由器的show run

 

Building configuration...

 

Current configuration : 9365 bytes

 

!

 

! Last configuration change at 15:50:15 UTC Sat Jan 10 2004

 

! NVRAM config last updated at 19:46:16 UTC Fri Jan 9 2004

 

!

 

version 12.1

 

no service single-slot-reload-enable

 

service timestamps debug uptime

 

service timestamps log datetime

 

no service password-encryption

 

!

 

hostname HRYY75WA02

 

!

 

no logging console

 

enable secret 5 $1$5YNt$1VC9uP552SPcl3.UuucX5/

 

!

 

!

 

controller SONET 8/0/0―――――――这个就是传说中的PA-MC-STM-1模块

 

framing sdh

 

!

 

au-4 1 tug-3 1――――――――――一共是12个E1线路

 

tug-2 1 e1 1 unframed―――――interface Serial8/0/0.1/1/1/1:0

 

tug-2 1 e1 2 unframed―――――interface Serial8/0/0.1/1/1/2:0

 

tug-2 1 e1 3 unframed

 

tug-2 2 e1 1 unframed

 

tug-2 2 e1 2 unframed

 

tug-2 2 e1 3 unframed

 

tug-2 3 e1 1 unframed

 

tug-2 3 e1 2 unframed

 

tug-2 3 e1 3 unframed

 

tug-2 4 e1 1 unframed

 

tug-2 4 e1 2 unframed

 

tug-2 4 e1 3 unframed――――――interface Serial8/0/0.1/1/4/3:0!

 

!―――以下是12个虚拟串口,对应上面的每一个E1分组,对于下面来讲每一个串口对应一个分理处/支行,对应一个电信提供2M时隙

 

interface Serial8/0/0.1/1/1/1:0

 

de.ion STM-E1 2M to WuYiXiLu fenlichu

 

ip address 16.202.99.185 255.255.255.252

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/1/2:0

 

de.ion STM1-E1 2M to YanJiangFenLiChu

 

no ip address

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/1/3:0

 

de.ion STM1-E1 2M to HuangXingNanLuFenLiChu

 

ip address 16.202.99.181 255.255.255.252

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/2/1:0

 

de.ion STM1-E1 2M to Cai'EBeiLuFenLiChu

 

ip address 16.202.99.229 255.255.255.252

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/2/2:0

 

de.ion STM1-E1 2M to KeJiYuan

 

no ip address

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/2/3:0

 

de.ion STM1-E1 2M to SiMenKouZiZhuYinHang

 

ip address 16.202.99.165 255.255.255.252

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/3/1:0

 

de.ion STM1-E1 2M to FuRongLuFenLiChu

 

ip address 16.202.99.193 255.255.255.252

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/3/2:0

 

de.ion STM1-E1 2M to GongDaSuo

 

no ip address

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/3/3:0

 

de.ion STM1-E1 2M to YinHeFenLiChu

 

no ip address

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/4/1:0

 

de.ion STM1-E1 2M to GongYuanFenLiChu

 

ip address 16.202.99.105 255.255.255.252

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/4/2:0

 

de.ion STM1-E1 2M to YanWaChi

 

ip address 16.202.99.109 255.255.255.252

 

encapsulation ppp

 

!

 

interface Serial8/0/0.1/1/4/3:0

 

de.ion STM1-E1 2M to NanHangFenLiChu

 

ip address 16.202.99.113 255.255.255.252

 

encapsulation ppp

 


这个我之前看过;我想问下华三怎么按时隙区分不同接口来配置IP呀

zhiliao_qQkXJN 发表时间:2021-05-18
2 个回答
已采纳
粉丝: 关注:

您好,请知:

H3C侧配置的参考命令如下:

controller Cpos8/3/1
e1 1 unframed
e1 2 unframed
e1 3 unframed
e1 4 unframed
e1 5 unframed
e1 6 unframed
e1 7 unframed
e1 8 unframed
e1 9 unframed
e1 10 unframed
e1 11 unframed
e1 12 unframed
e1 13 unframed
e1 14 unframed
e1 15 unframed
e1 16 unframed
e1 17 unframed
e1 18 unframed
e1 19 unframed
e1 20 unframed
e1 21 unframed
e1 22 unframed
e1 23 unframed
e1 24 unframed
e1 25 unframed
e1 26 unframed
e1 27 unframed
e1 28 unframed
e1 29 unframed
e1 30 unframed
e1 31 unframed
e1 32 unframed
e1 33 unframed
e1 34 unframed
e1 35 unframed
e1 36 unframed
e1 37 unframed
e1 38 unframed
e1 39 unframed
e1 40 unframed
e1 41 unframed
e1 42 unframed
e1 43 unframed
e1 44 unframed
e1 45 unframed
e1 46 unframed
e1 47 unframed
e1 48 unframed
e1 49 unframed
e1 50 unframed
e1 51 unframed
e1 52 unframed
e1 53 unframed
e1 54 unframed
e1 55 unframed
e1 56 unframed
e1 57 unframed
e1 58 unframed
e1 59 unframed
e1 60 unframed
e1 61 unframed
e1 62 unframed
e1 63 unframed


interface Serial8/3/1/1:0
description To G123
link-protocol ppp
mtu 1526
ip address 10.0.0.1 255.255.255.252
ospf network-type p2p
ospf bfd enable
mpls
mpls ldp

quit


多谢,还有接口下的IP地址也要按时隙表来进行配置吧,不能随意配置吧。 比如原设备接口Serial9/0/0.1/1/1/2:0下配置的IP,就得在华三的S1/0/1/22:0接口下进行相同配置吧

zhiliao_qQkXJN 发表时间:2021-05-18

这要看传输设备是什么品牌的,如果是中兴的传输设备,则对应的时隙就不是1对1了

得闲饮茶013 发表时间:2021-05-18

哦哦,那就只有两种可能吧,一种是一对一的,另一种是按时隙表来进行对应配置的;以防万一,就两种都准备了就没问题了吧

zhiliao_qQkXJN 发表时间:2021-05-18
粉丝:0人 关注:12人

多谢,还有接口下的IP地址也要按时隙表来进行配置吧,不能随意配置吧。

比如原设备接口Serial9/0/0.1/1/1/2:0下配置的IP,就得在华三的S1/0/1/22:0接口下进行相同配置吧


编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明