• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

MSR526+OSPF配置

2021-06-11提问
  • 0关注
  • 0收藏,66浏览
粉丝:0人 关注:0人

问题描述:

OSPF 对接思科设备,中间2层透传了一个华为交换机,目前想思科上配置BFD,双方看不到对方BFD 邻居

现在不清楚h3c 路由如何配置BFD和思科交换机对接,目前这种情况是不是能对接成功

华三的BFD配置麻烦贴下如何配置和OSPF联动。

组网及组网描述:

OSPF 对接思科设备,中间2层透传了一个华为交换机,目前想思科上配置BFD,双方看不到对方BFD 邻居

现在不清楚h3c 路由如何配置BFD和思科交换机对接,目前这种情况是不是能对接成功

华三的BFD配置麻烦贴下如何配置和OSPF联动。

2 个回答
已采纳
粉丝:155人 关注:0人

你好,请知:

以下是对接的案例,请参考:

3  BFD与OSPF联动互通配置举例

3.1  组网需求

MSR与Cisco设备之间运行OSPF路由协议,并使能OSPF与BFD联动,当BFD检测到链路故障时,本地OSPF进程将中断与对端的OSPF邻居关系。

图1 BFD联动配置组网图

 

3.2  配置思路

为了使能BFD,配置OSPF与BFD联动,并根据实际需要配置BFD参数。

3.3  使用版本

H3C版本:

本举例是在Release 2207P14版本上进行配置和验证的。

CISCO版本:

本举例是在RELEASE SOFTWARE (fc2)版本上进行配置和验证的。

3.4  配置注意事项

·     配置BFD建立会话时必须至少有一方的会话模式初始化设置为主动模式。缺省情况下,MSR设备的会话模式初始工作在主动模式。

·     通过控制方式建立BFD会话时,注意两端的参数设置是否适配:MSR设备工作在控制方式时,可以配置发送BFD控制报文的最小时间间隔的最小值为200ms,可以配置的接收BFD控制报文的最小时间间隔的最小值为200ms;而Cisco 这两个时间间隔最小值可以配置为50ms。

3.5  配置步骤

3.5.1  H3C路由器的配置

# 配置Loopback接口及接口地址。

<H3C> system-view

[H3C] interface LoopBack0

[H3C-LoopBack0] ip address 30.20.1.1 255.255.255.255

[H3C-LoopBack0] quit

# 配置与Cisco相连的接口GE0/1的IP地址和描述信息。

[H3C] interface GigabitEthernet0/1

[H3C-GigabitEthernet0/1] description to-cisco

[H3C-GigabitEthernet0/1] ip address 25.4.1.1 255.255.255.0

[H3C-GigabitEthernet0/1] quit

# 配置OSPF,并使能Loopback接口和GE0/1接口所在网段。

[H3C] ospf 1

[H3C-ospf-1] area 0.0.0.0

[H3C-ospf-1-area-0.0.0.0] network 25.4.1.0 0.0.0.255

[H3C-ospf-1-area-0.0.0.0] network 30.20.1.1 0.0.0.0

[H3C-ospf-1-area-0.0.0.0] quit

[H3C-ospf-1] quit

# 在G0/1接口下配置OSPF和BFD联动。

[H3C] interface GigabitEthernet0/1

[H3C-GigabitEthernet0/1] ospf bfd enable

# 在G0/1接口下配置发送BFD控制报文的最小时间间隔为200ms。

[H3C-GigabitEthernet0/1] bfd min-transmit-interval 200

# 在G0/1接口下配置接收BFD控制报文的最小时间间隔为200ms。

[H3C-GigabitEthernet0/1] bfd min-receive-interval 200

# 在G0/1接口下配置检测时间倍数。

[H3C-GigabitEthernet0/1] bfd detect-multiplier 3

说明:这里配置接收和发送BFD控制报文的间隔为200ms,检测时间倍数为3;实际应用时可以根据需要进行相应的参数配置。

3.5.2  Cisco路由器的配置

# 配置接口和相关接口的IP地址

cisco#configure terminal

cisco(config)# interface LoopBack0

cisco(config-if)#ip address 48.4.1.1 255.255.255.255

cisco(config-if)#interface fastethernet0

cisco(config-if)#ip address 25.4.1.2 255.255.255.0

cisco(config-if)#exit

# 配置OSPF路由协议,并使能Loopback0和fastethernet0所在的网段

cisco(config)#router ospf 1

cisco(config-router)#network 25.4.1.0 0.0.0.255 area 0

cisco(config-router)#network 48.4.1.0 0.0.0.255 area 0

cisco(config-if)#exit

# 使能IP CEF 功能:

cisco(config)#ip cef

# 在接口fastethernet0下使能OSPF与BFD联动,并配置BFD的发送间隔为200ms,最小接收间隔为200ms,检测时间倍数为3

cisco(config)#interface fastethernet 0

cisco(config-if)#ip ospf bfd

cisco(config-if)#bfd interval 200 min_rx 200 multiplier 3

暂无评论

粉丝:73人 关注:1人

这里刚好有个和思科对接配置的案例,参考一下

http://www.h3c.com/cn/d_201401/812789_30005_0.htm

暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明