• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

isis

2021-08-20提问
  • 0关注
  • 0收藏,125浏览
粉丝:0人 关注:0人

问题描述:

华三IS-IS路由引入的命令怎么敲

组网及组网描述:


最佳答案

粉丝:20人 关注:15人

import-route命令用来从其它路由协议或其它IS-IS进程引入路由信息。

undo import-route命令用来取消从其它路由协议或其它IS-IS进程引入路由信息。

【命令】

IS-IS IPv4单播地址族视图/IS-IS IPv4单播拓扑视图:

import-route bgp [ as-number ] [ allow-ibgp ] [ cost cost-value | cost-type { external | internal } | [ level-1 | level-1-2 | level-2 ] | route-policy route-policy-name | tag tag ] *

import-route { direct | static } [ cost cost-value | cost-type { external | internal } | [ level-1 | level-1-2 | level-2 ] | route-policy route-policy-name | tag tag ] *

import-route eigrp [ eigrp-as | all-as ] [ allow-direct | cost cost-value | cost-type { external | internal } | [ level-1 | level-1-2 | level-2 ] | route-policy route-policy-name | tag tag ] *

import-route { isis | ospf | rip } [ process-id | all-processes ] [ allow-direct | cost cost-value | cost-type { external | internal } | [ level-1 | level-1-2 | level-2 ] | route-policy route-policy-name | tag tag ] *

undo import-route { bgp | direct | eigrp [ eigrp-as | all-as ] | { isis | ospf | rip } [ process-id | all-processes ] | static }

IS-IS IPv6单播地址族视图:

import-route bgp4+ [ as-number ] [ allow-ibgp ] [ cost cost-value | cost-type { external | internal } | [ level-1 | level-1-2 | level-2 ] | route-policy route-policy-name | tag tag ] *

import-route { direct | static } [ cost cost-value | cost-type { external | internal } | [ level-1 | level-1-2 | level-2 ] | route-policy route-policy-name | tag tag ] *

import-route { isisv6 | ospfv3 | ripng } [ process-id ] [ allow-direct | cost cost-value | cost-type { external | internal } | [ level-1 | level-1-2 | level-2 ] | route-policy route-policy-name | tag tag ] *

undo import-route { bgp4+ | direct | { isisv6 | ospfv3 | ripng } [ process-id | all-processes ] | static }

【缺省情况】

IS-IS不引入其它协议的路由信息。

【视图】

IS-IS IPv4单播地址族视图

IS-IS IPv4单播拓扑视图

IS-IS IPv6单播地址族视图

我试了,敲不进去

在路上 发表时间:2021-08-20
1 个回答
粉丝:23人 关注:3人

在ISIS下使用Import-route命令重分布即可。

以下是配置案例,请参考:


组网说明:

本案例采用H3C HCL模拟器的S5820来模拟IPV6 静态路由与ISIS路由重分布的典型组网配置。SW1与SW2运行静态路由协议,SW2与SW3运行ISIS路由协议,为了实现物理机能够PING通SW3,因此需要在SW2配置静态路由与ISIS路由重分布。


配置步骤

1、按照网络拓扑图正确配置IP地址

2、SW1与SW2运行静态路由协议

3、SW2与SW3运行ISIS路由协议

4、SW2配置静态与ISIS路由重分布


配置关键点

SW1:

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW1

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]port link-mode route

[SW1-GigabitEthernet1/0/2]ipv6 address 1::1 64

[SW1-GigabitEthernet1/0/2]quit

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]port link-mode route

[SW1-GigabitEthernet1/0/1]description <connect to SW2>

[SW1-GigabitEthernet1/0/1]ipv6 address 2::1 64

[SW1-GigabitEthernet1/0/1]quit

[SW1]int loopback 0

[SW1-LoopBack0]ip address 1.1.1.1 32

[SW1-LoopBack0]quit

[SW1]int loopback 1

[SW1-LoopBack1]ipv6 address 4::1 64

[SW1-LoopBack1]quit

 

SW1 静态路由关键配置点:

[SW1]ipv6 route-static 3:: 64 2::2

[SW1]ipv6 route-static 6:: 64 2::2

 

SW2:

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW2

[SW2]int loopback 0

[SW2-LoopBack0]ip address 2.2.2.2 32

[SW2-LoopBack0]quit

[SW2]int loopback 1

[SW2-LoopBack1]ipv6 address 5::1 64

[SW2-LoopBack1]quit

[SW2]int gi 1/0/1

[SW2-GigabitEthernet1/0/1]port link-mode route

[SW2-GigabitEthernet1/0/1]des <connect to SW1>

[SW2-GigabitEthernet1/0/1]ipv6 address 2::2 64

[SW2-GigabitEthernet1/0/1]quit

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]port link-mode route

[SW2-GigabitEthernet1/0/2]des <connect to SW3>

[SW2-GigabitEthernet1/0/2]ipv6 address 3::2 64

[SW2-GigabitEthernet1/0/2]quit

 

SW2 静态与ISIS重分布关键配置点:

[SW2]isis 1

[SW2-isis-1]is-level level-1

[SW2-isis-1]network-entity 10.0000.0000.0001.00

[SW2-isis-1]address-family ipv6 unicast

[SW2-isis-1-ipv6]import-route direct

[SW2-isis-1-ipv6]import-route static level-1

[SW2-isis-1-ipv6]quit

[SW2-isis-1]quit

[SW2]ipv6 route-static 1:: 64 2::1

 

SW3:

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW3

[SW3]int loopback 0

[SW3-LoopBack0]ip address 3.3.3.3 32

[SW3-LoopBack0]quit

[SW3]int loopback 1

[SW3-LoopBack1]ipv6 address 6::1 64

[SW3-LoopBack1]quit

[SW3]int gi 1/0/2

[SW3-GigabitEthernet1/0/2]port link-mode route

[SW3-GigabitEthernet1/0/2]des <connect to SW2>

[SW3-GigabitEthernet1/0/2]ipv6 address 3::1 64

[SW3-GigabitEthernet1/0/2]quit

 

SW3 ISIS关键配置点:

[SW3]isis 1

[SW3-isis-1]is-level level-1

[SW3-isis-1]network-entity 10.0000.0000.0002.00

[SW3-isis-1]address-family ipv6 unicast

[SW3-isis-1-ipv6]import-route direct

[SW3-isis-1-ipv6]quit

[SW3-isis-1]quit

[SW3]int LoopBack 1

[SW3-LoopBack1]isis ipv6 enable 1

[SW3-LoopBack1]quit

[SW3]int gi 1/0/2

[SW3-GigabitEthernet1/0/2]isis ipv6 enable 1

[SW3-GigabitEthernet1/0/2]quit

 

测试:

物理机填写IPV6地址:



物理机能PING通SW3的loopback 1:



分别查看SW2、SW3的ISIS邻居信息:





分别查看SW1、SW2、SW3的IPV6路由表:

[SW1]dis ipv6 routing-table

 

Destinations : 11       Routes : 11

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 1::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 2::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : Static

NextHop    : 2::2                                        Preference: 60

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 4::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 4::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 6::/64                                      Protocol  : Static

NextHop    : 2::2                                        Preference: 60

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW1]

 

[SW2]dis ipv6 routing-table

 

Destinations : 11       Routes : 11

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : Static

NextHop    : 2::1                                        Preference: 60

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 2::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 3::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 5::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 5::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 6::/64                                      Protocol  : IS_L1

NextHop    : FE80::50BB:B1FF:FED0:307                    Preference: 15

Interface  : GE1/0/2                                     Cost      : 10

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW2]

 

 

<SW3>dis ipv6 routing-table

 

Destinations : 8        Routes : 8

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : IS_L1

NextHop    : FE80::50BB:ADFF:FE4E:207                    Preference: 15

Interface  : GE1/0/2                                     Cost      : 10

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 3::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 6::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 6::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

<SW3>

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明