• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

核心交换机和接入交换机的VLAN号要一致吗

2021-08-20提问
  • 0关注
  • 1收藏,638浏览
粉丝:0人 关注:0人

问题描述:

学校网络,每个楼层有都有接入交换机,每栋楼所有楼层的接入交换机连接到整栋楼的汇聚交换机,所有汇聚交换机最终接入核心交换机。之前接入交换机和汇聚交换机都没有做配置,核心交换机划分VLAN,其中VLAN25和VLAN30分别是给两栋教学楼。VLAN25划分了两个IP地址段,分别是172.16.10.1/23,172.16.15.1/24 sub。VLAN30划分了172.16.20.1/23,172.16.25.1/24 sub。本来打算在核心交换机配置DHCP,让接入VLAN25的教学楼内的办公电脑自动获取172.16.10.1网段的地址,教室电脑手动分配172.16.15.1网段,VLAN30类似。但是在核心上配置DHCP失败,现在考虑在接入层交换机配置DHCP,那么接入交换机上划分的VLAN号要和核心交换机的一致吗。如果一个VLAN下有两个IP地址段的这种情况,配置DHCP正常配置就可以了吗,有没有什么方法可以让172.16.10.1和172.16.15.1两个网段的设备都自动获取IP地址

组网及组网描述:


最佳答案

粉丝:27人 关注:3人

正常创建VLAN,配置VLAN IP,将VLAN划分到端口后再配置DHCP。

以下是配置参考命令:

将交换机的名字修改为SW1:

system-view

[H3C]sysname SW1

 

在交换机分别创建VLAN 10、VLAN 20:

[SW1]vlan 10

[SW1-vlan10]quit

[SW1]vlan 20

[SW1-vlan20]quit

 

VLAN 10的IP设置为:192.168.10.1 255.255.255.0:

 

 

[SW1]int vlan 10

[SW1-Vlan-interface10]ip address 192.168.10.1 24

[SW1-Vlan-interface10]quit

 

VLAN 20的IP设置为:192.168.20.1 255.255.255.0:

[SW1]int vlan 20

[SW1-Vlan-interface20]ip address 192.168.20.1 24

[SW1-Vlan-interface20]quit

 

将GI1/0/1端口划分到VLAN 10:

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]port link-type access

[SW1-GigabitEthernet1/0/1]port access vlan 10

[SW1-GigabitEthernet1/0/1]quit

 

将GI1/0/2端口划分到VLAN 20:

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]port link-type access

[SW1-GigabitEthernet1/0/2]port access vlan 20

[SW1-GigabitEthernet1/0/2]quit

 

开启DHCP功能:

 

[SW1]dhcp enable

 

创建DHCP地址池,命名为VLAN10,分配网段、子网掩码、默认网关、DNS:

[SW1]dhcp server ip-pool vlan10

[SW1-dhcp-pool-vlan10]network 192.168.10.0 mask 255.255.255.0

[SW1-dhcp-pool-vlan10]gateway-list 192.168.10.1

[SW1-dhcp-pool-vlan10]dns-list 114.114.114.114

[SW1-dhcp-pool-vlan10]quit

[SW1]

 

创建DHCP地址池,命名为VLAN20,分配网段、子网掩码、默认网关、DNS:

[SW1]dhcp server ip-pool vlan20

[SW1-dhcp-pool-vlan20]network 192.168.20.0 mask 255.255.255.0

[SW1-dhcp-pool-vlan20]gateway-list 192.168.20.1

[SW1-dhcp-pool-vlan20]dns-list 114.114.114.114

[SW1-dhcp-pool-vlan20]quit

暂无评论

1 个回答
大屿 八段
粉丝:18人 关注:3人

接入交换机太多,在接入交换机上配置DHCP太麻烦,要是核心确认无法配置的话,可以在每个楼的汇聚配置DHCP,网关也都放在汇聚上。另外因为你的接入交换机在楼层,也就是说同一个接入交换机可能有办公也可能有教室,最好还是在接入划分好vlan,把办公和教室的vlan分开,不然一栋楼一个vlan广播域太大了,划分完然后接入和汇聚之间trunk.


暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明