• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

dhcp 转接 主机拿不到IP

2017-07-26提问
  • 0关注
  • 0收藏,1015浏览
粉丝:0人 关注:1人

问题描述:

微信图片_20170726150202

拓扑如上 

Rout A配置


system


dhcp enable

dhcp server ip-pool 1

network 10.1.1.0 mask 255.255.255.0

gateway-list 10.1.1.1

dns-list 202.99.96.68


interface GigabitEthernet0/0

ip address 10.1.1.1 255.255.255.0

ip route-static 10.10.1.0 24 10.1.1.2


Rout-B配置


sytstem


dhcp enable

dhcp relay client-information record


interface GigabitEthernet0/0

ip address 10.1.1.2 24

exit


interface GigabitEthernet0/1

ip address 10.10.1.1 24

dhcp select relay

dhcp relay server-address 10.1.1.1

exit


组网及组网描述:

Rout-b的G 0/1口连接PC PC拿不到IP 是什么鬼?

最佳答案

已采纳

dhcp enable

dhcp server ip-pool 1

network 10.1.1.0 mask 255.255.255.0   //改成10.10.1.0 mask 255.255.255.0

gateway-list 10.1.1.1   //改成gateway-list 10.10.1.1

dns-list 202.99.96.68

您的意思是RA的G0/0上的IP段 与RB上G0/1必须是同一网段是吗?

zhiliao_30921 发表时间:2017-07-26

能解释下原理吗?我那么做为什么不能通?不盛感激。

zhiliao_30921 发表时间:2017-07-26

你做的是中继,中继向server发送DHCPDISCOVER的时候,会携带你配置dhcp relay接口的地址,告诉server要分配的网段,所以server上的ip pool要配置relay网段的地址。 另外,dhcp报文是不能跨三层的,所以才有了中继的出现,你下联的PC肯定是以中继地址作为网关,所以PC分到的地址和网关必须是和中继接口同一个网段,这样才能通信。

风干工程师肉干要不要 发表时间:2017-07-26

http://www.h3c.com/cn/Service/Document_Center/Routers/Catalog/MSR/MSR_5600/Configure/Typical_Configuration_Example/H3C_(V7)-6W100/201411/843965_30005_0.htm 万分感谢,请看下官方的典型配置 4.1的部分。他的接口地址与获取地址不在一个网段内,是不是官方的例子出现了错误?

zhiliao_30921 发表时间:2017-07-26

我看是在一个网段呀,dhcp relay的接口地址是10.10.1.1,PC获取的是10.10.1.2,没错呀。

风干工程师肉干要不要 发表时间:2017-07-26

dhcp relay配置: [RouterB] interface GigabitEthernet 0/1 [RouterB-GigabitEthernet0/1] ip address 10.10.1.1 24 PC上: Connection-specific DNS Suffix : Link-local IPv6 Address : fe80::d083:44cb:9d9b:71b7%21 IPv4 Address : 10.10.1.2 Subnet Mask : 255.255.255.0 Default Gateway : 10.10.1.1

风干工程师肉干要不要 发表时间:2017-07-26

我的问题!万分感谢!

zhiliao_30921 发表时间:2017-07-26
3 个回答
粉丝:2人 关注:0人

router A和ROUTER B分别是什么型号设备

模拟器做的,跟型号应该没关系,主机可以直接接到路由的3层口吗?

zhiliao_30921 发表时间:2017-07-26
粉丝:0人 关注:0人

dhcp enable

dhcp server ip-pool 1

network 10.1.1.0 mask 255.255.255.0   //改成10.10.1.0 mask 255.255.255.0

gateway-list 10.1.1.1   //改成gateway-list 10.10.1.1

dns-list 202.99.96.68

我希望,网关的IP地址是R-A的 G0/0地址,请问怎么破?

zhiliao_30921 发表时间:2017-07-26

那你直接把gateway-list 改成10.1.1.1就好了。但是不推荐这样子做。

zhiliao_9iWOQ 发表时间:2017-08-03
粉丝:0人 关注:0人

要保证获取的地址和接口地址在一个网段

http://www.h3c.com/cn/Service/Document_Center/Routers/Catalog/MSR/MSR_5600/Configure/Typical_Configuration_Example/H3C_(V7)-6W100/201411/843965_30005_0.htm 请看下官方的典型配置 4.1的部分。他的忌口地址与获取地址不在一个网段内。

zhiliao_30921 发表时间:2017-07-26

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明