• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

msr3600、msr26-00路由器使用电信公网ip不能上网

2020-09-19提问
  • 0关注
  • 0收藏,95浏览
粉丝:0人 关注:0人

问题描述:

两台都是同样的情况

msr3600、msr26-00

wan口设置电信给的固定ip始终无法上网,网关也不通。

ip是在正常使用的,在电脑单机上测试和其他路由器上使用都正常。

通过其他路由器lan口接入这两台的wan口也正常,就是直接设置在wan口就不正常。

难道必须要通过其他路由来中转吗???

这是什么奇怪的问题!!!

组网及组网描述:


最佳答案

已采纳
粉丝:155人 关注:0人

您好,请知:

关于使用公网IP无法上网的问题,以下是排查要点,请参考:

1、由于是固定IP,在路由器的端口上配置三层的互联,也就是配置IP地址。

2、在路由器上配置默认路由指向到外网。

3、路由器上需要部署NAT地址转换。

4、确保内网能路由到路由器上。

5、以下是MSR3600系列的用户手册链接:

https://www.h3c.com/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_3600/  

这些都没有问题哟。

zhiliao_VLS43i 发表时间:2020-09-19

看到您发出来的配置,有两条优先级一样的默认路由,应该是一内一外,建议将去往内网的默认路由修改为明细的静态路由看下。

Weijianing 发表时间:2020-09-19

两条都是往外的,只插公网ip不通,只插到其他路由器上就通。

zhiliao_VLS43i 发表时间:2020-09-19

那这样的话也是双外网了,可以在去往192.16810.1的这条路由加上优先级看下了。

Weijianing 发表时间:2020-09-19

不存在优先级的问题,我同时只插一条外网,另外一条就不起作用了。

zhiliao_VLS43i 发表时间:2020-09-19

意思是就算仅保留公网61方向的也不行?

Weijianing 发表时间:2020-09-19

你终于明白我的问题是什么了。

zhiliao_VLS43i 发表时间:2020-09-19

您好,我看到您配置的默认路由ip route-static 0.0.0.0 0 61.180.95.192下一跳地址是61.180.95.192,而端口的IP是 61.180.95.161 255.255.255.192,这个是26位掩码的地址,而61.180.95.192这个地址跟您端口配置的IP地址不在一个子网内。

Weijianing 发表时间:2020-09-19

需确认下下一跳地址是否指向正确

Weijianing 发表时间:2020-09-19

您端口的IP是61.180.95.161/26这个子网的IP范围是61.180.95.128-61.180.95.191,其中61.180.95.128是网络号、61.180.95.191是广播地址

Weijianing 发表时间:2020-09-19

确实是这个原因,正确的网关应该是61.180.95.129.但是在其他路由器和电脑单机上都使用这个错误的192的网关网络还都是通的,以至于没有检查这个错误,这真是说不通啊。

zhiliao_VLS43i 发表时间:2020-09-19

总算是找到问题所在了,非常感谢,在这个地方卡了一天了。我都以为见鬼了

zhiliao_VLS43i 发表时间:2020-09-19

您好,如果是按照26位的子网掩码计算,61.180.95.192这个IP是下一个子网的网络号了。这也有点说不通。

Weijianing 发表时间:2020-09-19
2 个回答
粉丝:53人 关注:0人

吧公网地址配置在路由器接口上能ping通接口上的地址吗?路由器接口必须是三层口,不能用二层口使用vlan-interface口对接。

按照说法应该是没问题的,可以提供配置确认下。

接口的ip是通的,就是网关不通

zhiliao_VLS43i 发表时间:2020-09-19

ip route-static 0.0.0.0 0 192.168.10.1 把路由器里面这个配置删掉,再试试

知了知了 发表时间:2020-09-19

也不是这个路由问题,配置看没太大问题。要不换个出接口。换到别的接口上去。

知了知了 发表时间:2020-09-19

换其他口也一样,感觉就像电信把这这两台H3c的路由器拉黑了,换上其他的路由器就正常了。

zhiliao_VLS43i 发表时间:2020-09-19

不大至于,你用电脑能直接上,说明电信没有绑定mac

知了知了 发表时间:2020-09-19
zhiliao_VLS43i 知了小白
粉丝:0人 关注:0人

使用公网ip始终不通

使用其他路由器中转就正常



[H3C]dis cu
#
version 7.1.064, Release 0809P28
#
sysname H3C
#
clock timezone Taipei add 08:00:00
clock protocol none
#
security-zone intra-zone default permit
#
dhcp enable
dhcp server always-broadcast
#
dns proxy enable
#
password-recovery enable
#
vlan 1
#
dhcp server ip-pool lan1
gateway-list 192.168.9.1
network 192.168.9.0 mask 255.255.255.0
address range 192.168.9.2 192.168.9.200
dns-list 202.101.224.68 114.114.114.114
#
controller Cellular0/0
#
interface Aux0
#
interface NULL0
#
interface Vlan-interface1
description LAN-interface
ip address 192.168.9.1 255.255.255.0
tcp mss 1280
#
interface GigabitEthernet0/0
port link-mode route
description Multiple_Line
ip address dhcp-alloc
nat outbound
#
interface GigabitEthernet0/1
port link-mode route
description Multiple_Line
duplex full
ip address 61.180.95.161 255.255.255.192
dns server 202.101.224.68
dns server 114.114.114.114
nat outbound
#
interface GigabitEthernet0/2
port link-mode route
description Multiple_Line
ip address 192.168.10.251 255.255.255.0
dns server 202.101.224.68
dns server 114.114.114.114
nat outbound
#
interface GigabitEthernet0/3
port link-mode route
#
interface GigabitEthernet0/4
port link-mode route
#
interface GigabitEthernet0/5
port link-mode route
#
interface GigabitEthernet0/6
port link-mode route
#
interface GigabitEthernet0/27
port link-mode route
#
interface GigabitEthernet0/7
port link-mode bridge
#
interface GigabitEthernet0/8
port link-mode bridge
#
interface GigabitEthernet0/9
port link-mode bridge
#
interface GigabitEthernet0/10
port link-mode bridge
#
interface GigabitEthernet0/11
port link-mode bridge
#
interface GigabitEthernet0/12
port link-mode bridge
#
interface GigabitEthernet0/13
port link-mode bridge
#
interface GigabitEthernet0/14
port link-mode bridge
#
interface GigabitEthernet0/15
port link-mode bridge
#
interface GigabitEthernet0/16
port link-mode bridge
#
interface GigabitEthernet0/17
port link-mode bridge
#
interface GigabitEthernet0/18
port link-mode bridge
#
interface GigabitEthernet0/19
port link-mode bridge
#
interface GigabitEthernet0/20
port link-mode bridge
#
interface GigabitEthernet0/21
port link-mode bridge
#
interface GigabitEthernet0/22
port link-mode bridge
#
interface GigabitEthernet0/23
port link-mode bridge
#
interface GigabitEthernet0/24
port link-mode bridge
#
interface GigabitEthernet0/25
port link-mode bridge
#
interface GigabitEthernet0/26
port link-mode bridge
#
security-zone name Local
#
security-zone name Trust
#
security-zone name DMZ
#
security-zone name Untrust
#
security-zone name Management
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class tty
user-role network-operator
#
line class vty
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 63
authentication-mode scheme
user-role network-operator
#
ip route-static 0.0.0.0 0 192.168.10.1
ip route-static 0.0.0.0 0 61.180.95.192
#
password-control enable
undo password-control aging enable
undo password-control history enable
password-control length 6
password-control login-attempt 3 exceed lock-time 10
password-control update-interval 0
password-control login idle-time 0
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
local-user admin class manage
service-type telnet http
authorization-attribute user-role network-admin
#
ip http enable
#
wlan global-configuration
#
wlan ap-group default-group
vlan 1
#
return
[H3C]





这真是个奇怪的事情。

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明